Paul Graham

Rega Owners Club

Recommended Posts

Super Wammer

Whoops - no Rega left-right - admired/bought their philosophy-stuff back at their prime ...

Share this post


Link to post
Share on other sites

Hi all, I own a Rega Planar 9 (1995), n° 331322, pre-owned, bought from Analogue Seduction last year, it's the MkI-version with RB900 pick-up arm, ceramic platter, external power supply. Nice table and so different from the LP12, Schopper TD124, SP10. Mounted an excellent MM Goldring 1042, pairs very well. Would like to use the Rega ARIA phono stage, anyone has one for sale? pre-owned? can't afford a new one. living in Brussels, BE.

Edited by boussven

Share this post


Link to post
Share on other sites

Hello everyone, I'm in a sticky situation here and hoping this won't cost me a fortune.

Long story short, my kids pressed BOTH tweeters in on the Raga Naos, yes, they popped the dome inwards.

How should I proceed? Is this a major problem? Can I fix it myself? What are my options? Are there replacements and how much would this cost me?

I'm in the UK if that helps.

Am desperate and am away from home, is this going to break the bank or is it as easy as unscrewing them and popping them out again?

So pleased I found this community as the search engines haven't given me anything so far.

Thank you for your knowledge in advance.

edit: My nerves took the best of me and I forgot to ask if there's any Naos owners here, would love to hear your thoughts as I haven't met anyone yet with the same set. 

Edited by RegaNaos

Share this post


Link to post
Share on other sites
Super Mod
2 hours ago, RegaNaos said:

pressed BOTH tweeters in

Try some sticky tape and pull , worked for me .

  • Haha 1

Share this post


Link to post
Share on other sites
Super Wammer

I would give Rega a ring, they are a remarkably helpful outfit normally. You could try sucking them out with a vacuum cleaner. It has worked for some people.

Share this post


Link to post
Share on other sites

cheers, I have watched all the videos and read about the ways to pull them back up, I'm not brave enough to vacuum it though, l'll start with the tape, see what happens...move to superglue..

Share this post


Link to post
Share on other sites
On 8/29/2017 at 06:10, Bazzer said:

Try some sticky tape and pull , worked for me .

Hi all, I had the same problem (Tannoy jupiter S plant series )  and the sticky tape did the job very well and been working fine for 30 year now , I am new to the owners club and would like to know if anyone has change the phono leads on the P3, from the RCA to BNC. My naim amp is BNC is it a good idea to do or would that affect the signal to much. I am using RCA to BNC adapter in the meantime 

Hoss 

Edited by Hoss

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.