Sign in to follow this  
orangeart

Help!

Recommended Posts

I need 2 things. An LP-12 belt, mine is just missing, can't find it anywhere.

I also need a soldering iron.....

Room 2

Share this post


Link to post
Share on other sites

OK, I don't need the soldering iron anymore, just an LP-12 belt.

Share this post


Link to post
Share on other sites

Got belt sorted, phew!

New problem. My room mates amp has blown up  :(

Now on my way back to Warwick to pick up a spare amp and a soldering iron.

Grrr...

  • Like 1

Share this post


Link to post
Share on other sites
Got belt sorted, phew!
New problem. My room mates amp has blown up 
Now on my way back to Warwick to pick up a spare amp and a soldering iron.
Grrr...

I've only just seen your post, so sorry if it's too late. I have 2 soldering irons and misc tools and general maintenance stuff if it may help. I'm in room 103. Ian

Sent from my SM-G935F using Tapatalk

Share this post


Link to post
Share on other sites

Well after going all the way back to Warwick to get an LP-12 belt we got back to Kegworth and set up. After 5 mins Andy's amo let go. Luckily i've got spare parts from an old build of my own. ... Back in Warwickshire. Back in the car we went! We got back about 1:30 this morning and had a well deserved pint or two. This morning we striped Andy's amp down to find a little metalIMG_20190317_091512.thumb.jpg.92f4e0e17cba4e6415a560a2898ed6e8.jpg prezzie from his daughters inside which had shorted the PSU and taken the amp channel down too. It was lucky the speakers were not killed!

Anyway at 5 to 10 we finally had glorious music 😀

Share this post


Link to post
Share on other sites

That brings back memories. I found such diverse things as crayons, lego and a jam sandwich in my video player when my kids were small. The JVC video player surprisingly lasted 13 years before it finally gave up the fight. They don't make them like that anymore. 

Pleased you are up an running now!

Share this post


Link to post
Share on other sites
Well after going all the way back to Warwick to get an LP-12 belt we got back to Kegworth and set up. After 5 mins Andy's amo let go. Luckily i've got spare parts from an old build of my own. ... Back in Warwickshire. Back in the car we went! We got back about 1:30 this morning and had a well deserved pint or two. This morning we striped Andy's amp down to find a little metalIMG_20190317_091512.thumb.jpg.92f4e0e17cba4e6415a560a2898ed6e8.jpg prezzie from his daughters inside which had shorted the PSU and taken the amp channel down too. It was lucky the speakers were not killed!
Anyway at 5 to 10 we finally had glorious music
Pleased to hear that you've fixed the fault and are open for wammers

Sent from my SM-G935F using Tapatalk

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.