vicdiaz

KazooServer acting up

Recommended Posts

I just noticed that KazooServer is no longer running on my QNAP NAS. I removed and reinstalled several times both KazooServer and the Mono Framework but I'm still getting a SIGDEV error:

=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================
 
Starting Kazoo Server: /usr/bin/KazooServer
Stacktrace:
 
 
Native stacktrace:
 
        /share/CACHEDEV1_DATA/.qpkg/KazooServer/usr/bin/mono() [0x4e8a0d]
        /share/CACHEDEV1_DATA/.qpkg/KazooServer/usr/bin/mono() [0x56d201]
        /share/CACHEDEV1_DATA/.qpkg/KazooServer/usr/bin/mono() [0x40e9f7]
        /lib/libpthread.so.0(+0x106f0) [0x7fa62236d6f0]
        /share/CACHEDEV1_DATA/.qpkg/KazooServer/usr/lib/KazooServer/libohNet.so(+0xee7c0) [0x7fa61d6bf7c0]
        /share/CACHEDEV1_DATA/.qpkg/KazooServer/usr/lib/KazooServer/libohNet.so(+0xec311) [0x7fa61d6bd311]
        /share/CACHEDEV1_DATA/.qpkg/KazooServer/usr/lib/KazooServer/libohNet.so(+0xca75a) [0x7fa61d69b75a]
        /share/CACHEDEV1_DATA/.qpkg/KazooServer/usr/lib/KazooServer/libohNet.so(+0xdd3ea) [0x7fa61d6ae3ea]
        /share/CACHEDEV1_DATA/.qpkg/KazooServer/usr/lib/KazooServer/libohNet.so(+0xdd4a9) [0x7fa61d6ae4a9]
        /share/CACHEDEV1_DATA/.qpkg/KazooServer/usr/lib/KazooServer/libohNet.so(OhNetLibraryInitialise+0x1b) [0x7fa61d6bb4eb]
        [0x41e97150]
 
Both KazooServer and Mono Framework versions are the latest ones.
 
Ideas?

Share this post


Link to post
Share on other sites

Sent e-mail to Linn's Helpline but no response so far.

How much do I miss the old forum... :'(

Share this post


Link to post
Share on other sites

Update!!!

Kazoo Server versions higher than 4.9.5 won't work while there is an open VPN session on my QNAP NAS. As soon as I closed the VPN session KazooServer worked perfectly. Now trying to get Linn to fix this since version 4.9.5 worked perfectly.

Share this post


Link to post
Share on other sites

Found out what is going on. I use VPN software in my NAS and KazooServer does not work when there is an open VPN connection (4.9.5 works perfectly no matter what). As soon as I close the VPN connection the latest KazooServer version works perfectly.

Share this post


Link to post
Share on other sites

I will stick with 4.9.5 then for now. by the way, how do you find out when there is a new version? The Linn software download page is pretty unhelpful, offering a download of the 'latest'. So is that the one I already have, or a newer one? There are no clues as far as I can see.

Share this post


Link to post
Share on other sites
16 minutes ago, J4j5j6 said:

I will stick with 4.9.5 then for now. by the way, how do you find out when there is a new version? The Linn software download page is pretty unhelpful, offering a download of the 'latest'. So is that the one I already have, or a newer one? There are no clues as far as I can see.

I think Konfig flags up a new version. 

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, MickC said:

I think Konfig flags up a new version. 

Not of KazooServer unfortunately.

This is the release history page:

https://linn-ui-buildartifacts-prod.s3-eu-west-1.amazonaws.com/applications/kazooserver/history.html#/platform/win32

And I just noticed there's no mention of QNAP builds there, only PCs and MACs. Does your NAS tell you about updates in the app centre?

Edited by timster

Share this post


Link to post
Share on other sites

No, the QNAP Kazoo Server never tells you of updates and neither does App Center. I think it is because it is manually installed product not from QNAP app store. Which is a real shame.

Thanks for the link to the linn build artifacts page. Did the VPN issue get fixed in a release?

Share this post


Link to post
Share on other sites

I don't use KazooServer so I have no idea. It won't be in the other releases - I believe the VPN issue was purely a QNAP one.

Share this post


Link to post
Share on other sites
Posted (edited)

@timsterKonfig flags up new betas (and before that, it flagged up regular updates) of Kazoo Server for me, but you have to select Kazoo Server in the configuration tab first. If there’s an update available there’s a marker over the cog icon on the right. 

Mick

Edited by MickC

Share this post


Link to post
Share on other sites
2 minutes ago, Tin said:

I'm not Timster 🤔

You’re not! Who knew? I shall edit my post accordingly. Sorry...

Share this post


Link to post
Share on other sites
38 minutes ago, Tin said:

Ah, now you put doubt in my mind... I think, thought.. I am not, was not, will not.. be Timster.. or am, did and do I? 🤔🤔🤔🤔

Hush now Tinster....

  • Haha 1

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.