moo-fi

Network Switches

Recommended Posts

Super Wammer

Before I retired, a few manufacturers implemented Cobranet for audio distribution and control, MADI was used as an alternative to stage boxes and we supplied some very large routing switchers using ATM, but things like RAVENNA were well in the future. 

In some respects it's easier when manufacturers use proprietary protocols, but it's also a real pain when one wants things from different suppliers to talk to each other. 

S

  • Upvote 1

Share this post


Link to post
Share on other sites

I am willing to bet your NAS is transcoding for the Linn. When the NAS sees a drop in throughput, using rate adaptive transcoding, it will drop the rate. I can reproduce this using my Synology NAS.

The solution is to turn off transcoding on the NAS or have the Linn connect using Windows SMB file sharing (I don't know what the capabilities are of the Linn). Do not use DLNA.

Edited by drummerjohn
  • Upvote 1

Share this post


Link to post
Share on other sites

Thanks, this sounds very possible, unfortunately DLNA is the default for the Linn, which is being fed from a Synology NAS.  

I will do some digging to see if there are alternative options, but I am not holding my breath

Share this post


Link to post
Share on other sites

On your Synology goto Media Server >  DMA Compatibility > Untick Enable Audio Transcoding and try that. That only applies to files other than WAV or MP3 pretty much.

However, now that you have a semi-reasonable switch that isn't introducing errors the Synology should respond better.

Latency - over wire should be 5ms or less from device to NAS. If you are seeing anything above that then you are either using wireless or you have a major switch problem.

Edited by drummerjohn

Share this post


Link to post
Share on other sites
Super Wammer
28 minutes ago, drummerjohn said:

I am willing to bet your NAS is transcoding for the Linn. When the NAS sees a drop in throughput, using rate adaptive transcoding, it will drop the rate. I can reproduce this using my Synology NAS.

The solution is to turn off transcoding on the NAS or have the Linn connect using Windows SMB file sharing (I don't know what the capabilities are of the Linn). Do not use DLNA.

Why? Also, what are the alternatives?

Share this post


Link to post
Share on other sites

In this context the Synology will try and use a DLNA profile that may not work well with the Linn and transcoding will take place. Under Media Server > DMA Compatibilty > Device List you will see all your devices that have been connected to the Media Server and what type of DLNA profile has been used. Not all devices are equal so Synology and others have created profiles to make them work together better.

The alternative is to use Windows SMB or NFS. Files are then transferred\streamed without any modification.

I have had many streamers and none of them have been as good as KODI. KODI doesn't need to use DLNA or a NAS to transcode as it can decode anything.

  • Like 1

Share this post


Link to post
Share on other sites

That is transcoding disabled and the Linn is still working.  The profile is a default profile: UPnNP AV.

Now to change switches (and cables as I just installed Cat 6a everywhere) to see what happens.  The measurements take a while.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.