• advertisement_alt
  • advertisement_alt
  • advertisement_alt
chronicallyme

Have I Been Sold a Dud?

18 posts in this topic

Picked up a 10 hour use Denon DL-110 the other day and just came about fitting it.

All went fine, aligned it, adjusted the tone arm etc....then had it running. Left channel (red) is wonderful, but nothing but a buzz though the right channel (white). Checked the wires on terminals, and correct colours, checked the Project manual that the wiring colours where the same as the Denon - all fine. Scratching head.

Put the Ortofon back on and all is working fine. Both channels crystal.

It was bought off a person on ebay, nice guy, did a reasonably offer on it I was happy with, he seems very legit, 100percent feedback over hundreds of sales and had some nice hifi kit he was selling.

Am i being stupid or have i missed something on the Denon?

0

Share this post


Link to post
Share on other sites

Try swapping R and W over on the cart to see if the noise moves

0

Share this post


Link to post
Share on other sites

German/Dutch - polite ' unfortunately there is a problem'

British - YOU SOLD ME SOMETHING BROKEN IM REPORTING YOU TO EBAY AND PAYPAL AND THE QUEEN

That what you meant? :)

Im refitting the Denon now and swapping the channel wires

0

Share this post


Link to post
Share on other sites
Left channel (red) is wonderful, but nothing but a buzz though the right channel (white).

Just a small point but the red is the Right channel and white the Left channel.

It must be something in the water at the moment. I also bought an MC cartridge on eBay recently but it's going to have to go back as the right channel is as silent as the grave. Shame - the left channel sounds really nice!

0

Share this post


Link to post
Share on other sites

I swapped the right channel over, and now the right speaker works, the left is dead as a doornail , well not dead, it has a lovely hum to it.

Gutted, I was really looking forward to this, from what I can hear through the single channel it sounds sublime, its perfect for my bluegrass/americana/singersongwriter tunes.

So, general consensus, been sold a duff?

0

Share this post


Link to post
Share on other sites

Does rather sound like it. The wires that come from cartridges coils are very thin pretty fragile and they could just have broken. MM coils, being stationary, tend to be more reliable, but I bought a V15-V body a few months ago that had an open circuit coil.

Hopefully, if the seller is genuine, there shouldn't be any problem with a refund.

S.

0

Share this post


Link to post
Share on other sites

Unfortunately it was sent with Hermes. It was EXTREMELY well packaged, but I know from friends who have worked for Hermes as couriers, the Bermondsey depot near me play football with parcels and leave tv's out in the rain when they are very busy - I generally avoid them at all cost myself.

Guess i'll have to drop him a mail. To be honest, I think he is completely genuine and will now probably be losing out because of what could of been bad handling by the courier.

- - - Updated - - -

one of the securing nuts had fallen off the bolt as well and was bashing around inside the case. He had worked the other side on a good 4-5 threads, so its obviously seen some action in transit. I was originally more concerned over the stylus but that sounds fine!

0

Share this post


Link to post
Share on other sites

just a quickie but it might be the leads themselves? I mean if you 'swapped' by putting the red lead onto the white contact and Vi Ve. then it may be a bust lead...my headshell allows the whole lead to be removed (squeezy tags both ends on the leads) so if you can, just try a new lead on the dodgy chanel first....replacement leads are, after all, your problem, not his, and quite cheap?

0

Share this post


Link to post
Share on other sites
just a quickie but it might be the leads themselves? I mean if you 'swapped' by putting the red lead onto the white contact and Vi Ve. then it may be a bust lead...my headshell allows the whole lead to be removed (squeezy tags both ends on the leads) so if you can, just try a new lead on the dodgy chanel first....replacement leads are, after all, your problem, not his, and quite cheap?

It's not, because the Ortofon cartridge works straight away in both channels when connected back, unless I am misunderstanding you?

- - - Updated - - -

Good luck Mike. ( Glad you like the TQ leads!)

Thanks dude, absolutely brilliant they are :)

0

Share this post


Link to post
Share on other sites

I once had a Dynavector D17 break just by moving my tt. One channel completely dead. Seems they are very delicate so to see it being damaged during transit. Shame for you and the seller.

0

Share this post


Link to post
Share on other sites
I once had a Dynavector D17 break just by moving my tt. One channel completely dead. Seems they are very delicate so to see it being damaged during transit. Shame for you and the seller.

Thanks dude, yeah I think Hermes is to blame. The seller has been fine about it, feel a bit sad for him as well, as trying to get hermes to compensate something like this would be impossible.

So im on the look out for another Dl-110!

0

Share this post


Link to post
Share on other sites
It's not, because the Ortofon cartridge works straight away in both channels when connected back, unless I am misunderstanding you?

Ah...no I missed the post with the ortofon atempt. As you were. Good luck! :)

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.